Alembic Import Export Frame Rate Issue Blender

  • Support Agent Comment actions Permalink

    Hello Rene!

    Thank you for contacting us.

    The issue that you mentioned has been solved in version 6.0.537 (our latest version as of now).

    Please download and try the patch update version.

    Should you have further questions, please let us know.

  • Mario Comment actions Permalink

    I'm having the same issue and am extremely annoyed given that I'm paying 40 a month for something that doesn't work. This was the response another user kindly left me:

     

    Hi Mario,

    I don't have direct experience with this issue, but I just caught a comment in a tutorial stating that MD cannot do 24fps, and you must bring in your avatar/animation in 30fps.  Here's where I heard this.

    https://youtu.be/jUFz7GMXCI4?t=298 


    I don't know what a work around would be and I hope MD will fix this because I only work in 24fps and don't want to do 30fps.

    Hope this helps.

  • Rene Gibson Comment actions Permalink

    Yeah I caught the same comment on a forum here about 30fps. Definitely problematic! I have solved the issue by defaulting to 30 fps, but I thought I'd flag the issue here hoping that Marvelous fixes it in another patch soon. The latest patch for 10 says the issue is fixed in the release log but it clearly is not. 

  • Rene Gibson Comment actions Permalink

    Hi Sonia, 

    Thanks for reaching back. As mentioned in my initial comment I had seen this issue as being fixed in the release notes however the issue persists even in 6.0.537. At least in Blender - exporting the alembic data in 24 fps, importing in 24fps and exporting back to Blender in 24fps still does not sync correctly. 

    Forced to be working in 30fps until this is resolved unfortunately. 

  • Mario Comment actions Permalink

    Hey Rene. I as well got the update. I as well had to use the 30 FPS, but was able to change the frame rate to the final output in Blender to 24FPS. Here's the test I did. I still had to add a solidify modifier so that the body mesh doesn't go through the clothing. Not sure anymore on who's end that is.

     

    https://www.youtube.com/watch?v=7wZm7a1h6aE

  • Rene Gibson Comment actions Permalink

    Interesting Mario... You're saying you selected 30fps on import but 24fps on export? Did you also export the alembic from Blender to MD at 30 fps? 


  • Mario Comment actions Permalink

    The naked character to which I am going to simulate the clothing on comes from Iclone at 30 FPS. Once it’s in marvelous Designer and I create the clothing and run the simulation, from there, I export at 30 FPS (because for whatever reason even though MD offers to render at 24 frames, the 24 option just doesn’t work. I dare even say the 30 frames per second doesn’t work properly because when it gets to blender, the body starts to go through the clothing, mind you it’s only slightly, but still annoying . The fix for that was to add the solidify modifier and increase it ever so slightly like just a pinch, and then the body no longer goes through the clothing.)

    So at this point you have your character, the clothing, and the simulation which all came out of Marvelous Designer at 30 frames per second.

    Now here’s the important part. Even with the clothing, the character and the simulation all sitting IN blender at 30 frames per second, I forgot what the tab was called, but on the right there’s a little drop-down where you get the change the scenes frame rate. That is where you choose 24 frames per second.

    So in other words, even if whatever you important Into Blender comes in at 60 frames per second, 30 frames per second or any frame rate, if you change the frame rate output in blender, it doesn’t matter at what frame rate the characters and whatever else you have in your scene comes in at. It will still be exported out of blender at 24 frames per second if you choose such a frame rate.

    That’s the only way I’ve been able to make this work after a month of tinkering with it. The part that begins to concern me is, what happens if I have a character and I’m recording the voice animation at 30 frames per second and then after that entire process I just described, frames are missing which would throw the voice audio out of sync. But I’m definitely dealing with one problem at a time LOL. I hope any of this has helped. It has been a pain searching for answers online and I’m annoyed at paying $40 a month for something that barely works.

  • Angel Angel Comment actions Permalink

    When you view a garment in MD and export you may be looking at two varying results, thin mesh verse thick mesh. So it's crucial you know how and what to set up on export. Any MD garment has a mid cloth plane (thin mesh) and as a consequence if you animate you should ensure your avatar's skin offset and the garments offset for all patterns and fabric (thickness) these are accumulative are set 'prior' to export or animating. Blender can precisely (I use this app) mimic the exact thickness you see in MD when using the thicker textures view and yet export a thin mesh, so yes using the solidifier in the stack within blender will bring a garment back into tolerance for the offset collsion as you viewed it happening in MD. This is not a fault, it;s actually a mis-understanding on how the offset tolerance work between applications. You can also add in blender most of the detail (eg: seam normals between patterns as well, using more modifiers in the blender stack > a one click process), this will give you exactly what you see in MD BUT you must set the tolerances to be exactly the same. So again maybe a case of not having insight to the importance of these details between applications when you animate. You must set these correctly.

     

    I got a bit confused by you post regarding the animation FPS aspect Mario, The blender body will never go through the clothing if you set it to the correct tolerances. MD is extremely accurate in how the collision offsets work and I have never had a fault with this in blender if my setup follows the same as back in MD, so that is maybe a check procedure you need to include in your workflow, to mitigate that in future would be my advice. Check out how offsets work and then set the offset plane in Blender to be exactly the same as the 'ACCUMULATED' collision offset tolerance in MD for your garment assembly.You need to check each pattern piece and also the general fabric offset settings in concert with the avatars skin offsets (which can all vary). So a checklist is crucial here.

     

    You should be okay in blender with output from MD, I have been doing that for 8 years and never had an issue, maybe you have some problems with import setup in blender, what version were you using > the production ready supported (debugged) version or the Blender beta versions? There are differences here so stating what version (build) of blender you are using helps pin-point the technical issue, as not all versions of Blender are created equal.

     

     

  • Rene Gibson Comment actions Permalink

    I've of course tried changing the playback framerate in Blender. but that is what causes the sync to be off in the first place. My armature plays back at which ever frame rate I determine in Blender, but the alembic clothing mesh from MD still plays off sync... 

     

  • Angel Angel Comment actions Permalink

    Alembic and how it is treated is again based on what version of blender you may be using. What version of blender are you using ?

    All these issues can be overcome relatively simply but maybe get back to stating what versions (and builds) of both software's you are using.

    See notes from blender about these pending changes 2.83 verse 2.90 for example and then what constitutes official support or unofficial is also a point you need to be certain about when using Blender alembic : > Link

    In order to help, you really need to provide the detail. That's a prerequisite for any reasonable technical diagnosis, what you may find is that both issues are to do with Blender and only blender, so be prepared for that outcome and maybe eating some straw hats!

  • Rene Gibson Comment actions Permalink

    Of course! Just to clarify I have no thickness issues. I'm just speaking sync here. 

    Using the latest MD 10 Patch. And Blender 2.91.2

    I would like to note that half my project was done in MD 9 and this wasn't an issue at that time. 

  • Angel Angel Comment actions Permalink

    Process changes when new builds come out, just like that link shows with blender 2.90+ and alembic ...  then maybe the 'interim' fallback position is to use the MD Archive version if you have a project compatibility issue, they provide them for backwards compatibility, they are in the archive section of your online account.

     

    As for the latest MD10 (6.0.537.32823) I will give it a test as this is only a few days old, but frankly I haven't noted any issues when doing animations between MD and with blender, although I do use the Blender production version LTS , the fix updates for the 2.9 series are generally applied to that LTS robust build. However I will test with BL 2.91.2 later on today and see what I get.

     

    :-)

  • Support Agent Comment actions Permalink

    Hello Rene Gibson and all,

    This fps issue has been resolved in our latest Marvelous Designer version of 6.0.575. Thank you for your patience.

    Please download the patch version and check this issue :) Hope this helps.

    Have a lovely day!

  • Dror Revach Comment actions Permalink

    Hi Marvelous guys,

    I am using version 6.0.623

    I have a 60FPS character animation brought in, and simulated.

    When I export alembic I get something else not 60FPS but similar to 30FPS.

    when loading into Maya, i have to mess around with the speed to make it work.

    I went through this thread and it seems this issue was suppose to be resolved. any ideas?

     

Please sign in to leave a comment.