MarvelousDesigner Help Center

How can we help you?

Smooth Avatar Does Not Work

  • Rosemary Comment actions Permalink

    Turn on the Strain mapping and see how tight your pants are around the hips.  If you see a lot of red, it's too tight and the pattern should be adjusted to loosen up that area.

     

  • Angus Hume Comment actions Permalink

    Thanks but there is no strain there, the problem is the avatar is low resolution and the smoothing option is disabled. There should be a checkbox above the slider, that must be enabled first before the slider works.

  • Wouda Suzana Comment actions Permalink

    I have the same problem! There was in former versions, Marvelous 7, the possibility just to smooth the avatar. In CLO 3D the function was dividing mesh. That worked perfect! I am wondering why this function is not available anymore in the current versions of Marvelous Designer and CLO 3D. Unfortunately its a big issue in the end of a project when decreasing the particle distance. And by the way it hast nothing to do with the tightness of the garment.

  • Angus Hume Comment actions Permalink

    I explored further and see the following behaviour.

    • The default avatars do not show the smoothing checkbox in the properties panel, so smoothing cannot be enabled, the slider has no effect.
    • The v1 avatars show the checkbox but clicking it shows an error message saying the mesh cannot be divided.
    • The Sansar avatars show the checkbox and also allow the checkbox to be selected, then the slider to be used and the avatar is smoothed.

    This seems like a big problem to me. I have only recently starting using MD so have no experience of previous versions. However I have managed a workaround. After my sim was done I went to the sculpt tab and dabbed the smoothing brush on the really bad parts and they cleared up easily. This is hardly ideal though, as invoking another simulation removes the sculpting and the facets return. 

  • Angel Angel Comment actions Permalink

    Strange that avatar sub division (smoothing) is giving you that issue. 3mm is perhaps to fine for the cloth mesh distance - you are potentially not getting any benefit from that resolution on the trouser legs . You would generally be fine with 5mm for a simple garment at high resolution or even slightly higher for the trouser legs as you can attack micro creasing with displacement maps and normal's in localized cloth areas of high cloth poly count if you need some high detail in some seam area. You don't need to always make the whole cloth pattern a high poly count.

     

    MD8 below cloth set to 3mm particle distance > Did you switch your simulation over to > CPU compute > Simulate Complete (non linear)

    3mm particle mesh distance above on a pair of trousers shrunk to 85% for a skin tight simulation with the avatar smoothing set to 2. I could easily ramp that up to 5mm particle distance and still get a smooth sim on the backside.

    If you don't notice the difference above at 10mm cloth relative to the 3mm at the top - you are likely pushing around too many cloth polys for your garment without any real gain.

     

    Try checking you have the simulation set for that beauty pass simulation quality.

    :-)

  • Angus Hume Comment actions Permalink

    Thanks for the tip on the hidden simulation mode. It does give a bit more detail but does not fix the facets that I showed in my screen grab. If I take my particle distance back up to 10 you cannot see it but I want the higher resolution of at least 5, but 3 looked better. In your example though you smoothed the avatar to 2, I cannot do that on the current default avatars in v9.5 because the option is unavailable. Which is the issue I am having. If use avatar smoothing of 1 or none can you see facets like I am? PS I have only just starting using MD, but I think they introduced new avatars in 9.5? At any rate I am only able to smooth the Sansar ones.  

  • Angel Angel Comment actions Permalink

    You may need to change your approach.

    If you still have the old Marvelous Designer base library (usually saved in your documents under the MD version control folders when you install a new version) try opening up one of the older avatars, they should still be archived there, maybe that will help to use that older avatar.

     

    My suggestion would be - try exporting the avatar in it's current state of mesh and place it into modo or blender and subd it and export it back into MD as either a finer mesh or even try a copy of the current avatar exported as FBX and re-import as new avatar and see if you can then apply the avatar smoothing to that copied version.

     

     

  • Angus Hume Comment actions Permalink

    Thanks so much for such detailed reply. I will go through all of this! I should clarify though I do not have an old version of MD, I only just bought 9.5 a couple of weeks ago. In 9.5 I have the new default avatars, a folder called v1 and another called Sansar. My comments on the Sansar avatar were only to indicate what avatars were allowing smoothing in MD and which were not. I'm not using Sansar application. I am exporting the garment to Modo for texturing and rendering. I'll look into exporting the default avatar and reimporting to see if smoothing is then enabled. But will I lose the poses and animations currently available on these in MD? 

  • Angel Angel Comment actions Permalink

    Okay - most of that post content I made was irrelevant then, I would send a message to MD directly via your account and alert them to that fact and see if they can rectify it or if it's a known problem.

     

    I used to use modo for product rendering, but for fabrics garments it really wasn't up to it as the shader stack couldn't handle the high resolution level of texture maps, range of spectral light I needed to feed into it (rear illumination of weave ID maps for light transport). Sad thing about many shaders they don't do fabrics well. So I created my own digitization hardware and approach to organically creating CG fabric quality. Which paid off - as I get this realtime capability flowing through from a small sample via digitization, auto masking, yarn ID maps, normals, A.I. organic reconstruction to structured weaves in under 30 seconds.

     

  • Angus Hume Comment actions Permalink

    Wow, that's some detailed materials. Fantastic. Indeed that kind of detail is not Modo's strength. Although the texture size you could probably get around by using tillable EXRs. I'm just using textures from Substance Source in this case and ignoring the SSS or opacity between the weave for this job. I've seen some nice looking fabric scans from Chaos Group with VRScans, as I think they are capturing bidirectional lighting information that cannot normally be done with Modo's native shading. Very. nice wood materials too. 

     

    I found a quick workaround for the faceting, I just sculpted a bit of smoothing on the few contact points and all is good. But I will send a query off to support. Thanks again! Oh and here's some of my fabric rendered in Modo.

  • Angel Angel Comment actions Permalink

    You can do a garment pressure (contact) point view in MD to give you a look at where all the problem areas are on the avatar come in direct contact with the cloth - so yes smoothing it out locally is a work-around for now, best to get them to sort that out, it should work.

  • Angus Hume Comment actions Permalink

    I've had a reply from support now, the smoothing feature is unavailable on the new v9 default avatars with no plans to change that in the next version.

  • Angel Angel Comment actions Permalink

    Down to using the MD8 avatars then. Alternatively it looks like they are taking the approach that you sub divide your avatar outside MD and bring it in as you need for your project. Which is how I tend to work anyway and I imagine with custom characters in CG that is the norm when creating clothing for a CG character.

  • Angus Hume Comment actions Permalink

    Seems strange to me though. I tried exporting as FBX and reimporting and that mesh allows smoothing just fine. However the new avatars have a number of useful animation sequences which I then cannot use on the reimported mesh... as far as I can tell. 

  • Angel Angel Comment actions Permalink

    As long as your mesh incoming is a quad geared for subd it should be okay. Otherwise > When you import a new avatar character > select the avatar > go to the property editor > surface > divide mesh > 1~3

Please sign in to leave a comment.